Jump to content
   
RiverTowy

Engine management light not coming on

Recommended Posts

2006 Connect T220L SWB 1.8 Diesel. No engine management light on when key turned in ignition on starting. Should it light up? All other dials/guages/LEDS work fine.
I have run the cluster self test and the EML does illuninate, so the LED is good.

Share this post


Link to post
Share on other sites
 

It has been suggested on another forum, that the problem is probably a processor communication to the CEL fault/malfunction.

I cannot afford to pay £150+ to take it to a Ford garage to be put on a diagnostic tool.

How would I go about getting this investigated? 

Share this post


Link to post
Share on other sites

 

On cars I've owned, when key is turned to first position, ACC, all dash warning lights will turn on to indicate that they work.  Assumption is that your car should do the same thing.  

 

On most cars which fail government inspection, the obvious fix is usually a bulb or fuse.  We know that the light can illuminate, which means you can rule out the first obvious test.  No need to test the lamp.  No need to test the fuse.  

 

The least expensive option is to download ForScan for free.  ForScan can run "key on, engine off" and "key on, engine on" tests,.  This may work if your vehicle is compatible with ForScan.  There are a lot of scan tools on the market, and some are Ford specific.  But buying your own electronic diagnostic equipment may also be cost prohibitive.

 

 You will need a computer and OBD II connector for Forscan.  Most people suggest using a laptop computer with a cable, as opposed to a tablet computer with bluetooth and/or WiFi connection.  The cable is stable, and there is less of a chance that you will lose connection to the computer in mid-test.  A laptop could be plugged into an extension cord, so that you don't risk low battery failure in mid-test.  The laptop computer version of ForScan may be a better version of the software.  

 

You could also do something obvious to trigger the check engine light, just to see that if there is a problem, the light will come on.  I've heard of people taking the fuel cap off, then turning on the car.  In theory, if the fuel cap is defective, loose, or off, the check engine light is suppose to turn on, to indicate that you have a problem.  

 

Another option is to use a wiring diagram and check wiring for a bad connection somewhere.  

 

Are there any independent service shops in your area who have diagnostic tools or diagnostic computers?  Is there an independent shop in your area whom specializes in Ford vehicles.  Some "tuner" shops, or "speed" shops, are more knowledgeable about electronic diagnostics since they dyno-tune, and may have better electronic diagnostic equipment than shops whom do mostly mechanical work.  Some independent shops can perform the diagnostic for less than what Ford will charge you.  

 

There is also a person online, who has posted tons of great videos, and many follow his advice on repairs and maintenance.  You could try contacting him.  Maybe this is something that a professional mechanic sees, has a simple solution for, and us non-professionals just don't know about.  As reference to the video below, this guy sees more than most people, and as he points it all out, it was all obvious and people just don't see what's in front of them.

https://m.facebook.com/FordTechMakuloco/

https://www.youtube.com/user/FordTechMakuloco

 

Share this post


Link to post
Share on other sites

Does your engine have a oil pressure gauge or light? If a light, does that come on? Check the Sender wire on the engine  oil pressure  sender it could be involved?

Share this post


Link to post
Share on other sites

Fifty150 thank you for such a comprehensive and informative reply.

I broke down the other day, coolant temerature sensor failed. The CEL/EML did not come on.  New sensor got me going again. Mechanic read fault codes and cleared them.

Subsequent to that, out of interest, he read them again couple days later.  U1262 and B1318 present.

I have now got ForScan and a USB ELM327.  Not used it yet though.

GBL, oil pressure indicator is a LED.  It comes on in startup position just like it should and goes off on starting.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×