Jump to content
   
Sign in to follow this  
Paul Hauser

Installing 2DIN nav in '15 Gen2 with Mechless radio

Recommended Posts

Its been a little while since I did this install but I took photos and planned to write about it when the weather was nasty. today the weather is nasty.

 

I have a '15 Transit connect LX cargo van with the very base package. I bought this model believing that it would be a great platform to build whatever I wanted. That's been true some of the time, but the very basic model has significant differences in the wiring harness and in fact some of the harness simply isn't there going to the cargo area. The "mechless" radio is a big difference. Mechless radios have only AM/FM, no CD player. There was  no 4" screen above my radio and no steering wheel controls.

 

Researching on the Crutchfield website said there were no radio install kits for my vehicle, I knew I could fab something, but that wasn't the only problem I would run into. Since I had no 4" screen and the install kit had no provision for not having one I decided to install a switch panel in that spot. I started with paper mach-up, then made one from Plexiglass. Why Plexiglass? I had some, and its easy to fab since you can see through it.

 

5lZnC0y.jpg

nsoJaf8.jpg

 

Here's new and old next to each other.

 

KuwPh0E.jpg

 

When you pull out the Mechless radio there's a big hunk of useless plastic.

 

TwJTuji.jpg

remove it.

DkLPsuu.jpg

 

Now there's plenty of room. 

Before any of you comment, my van is filthy. It will remain filthy through out these photos and probably throughout its existence.

I had to pull out the seat to run the wires for the backup camera under the floor matt, as well as pull the canter console and trim around the shifter.

 

oc8oc60.jpg

What a mess.

 

The Nav and XM antennas tuck in nicely under the little visor piece.

fvcCBjl.jpg

3kN2E0m.jpg

 

and I added a USB port that goes to USB2 on the radio for Android Auto. This is a convenient spot to plug in but very inconvenient when taking things apart, I would rethink this if I were doing it again.

 

 mC8UIKj.jpg

 

After getting all the wiring and hardware complete, with much excitement, I switched the power on..... and nothing happened. just a blank screen. talk about a sinking feeling.

after a few phone calls that I should have made when I started this project I found that I had used the wrong wiring harness from Metra. While most of you will use the XSVI-5524-NAV CAN data interface, those of us with mechless radios need the simpler 70-5524. Even though I do have a CAN system in my van, the radio doesn't use it and the wires aren't there. The only thing that I don't have in the end is the speed signal. I think I could find it under the instrument panel, but I haven't tried so far. It works fine without it.

 

2leHaNL.jpg

final project working.

 

so what do the switches do?

on of them works these cargo area LED strips.

 

SIpu5Xq.jpg

 

I hope this has been helpful and inspires you to do your own custom install.

 

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×