Jump to content
  • Custom Search


Sign in to follow this  
No name displayed

Jerking

Recommended Posts

Have a 2018tc cargo. 2.5 motor. 50k miles. Upon light to medium acceleration I get soft jerking/shaking the whole vehicle. Hard accel yes fine. Motor runs great. Spark is good and so is intake and maf sensor. I don’t know what it could be. Thanks for any help 

Share this post


Link to post
Share on other sites

Tire(s) or CV-joint/axle shaft.

Share this post


Link to post
Share on other sites
33 minutes ago, mrtn said:

Tire(s) or CV-joint/axle shaft.

I have new tires about 2 weeks old. But I can bring it back to shop

Share this post


Link to post
Share on other sites
On 9/14/2020 at 4:40 PM, No name displayed said:

I have new tires about 2 weeks old

Did this issue start before or after the tires? If after check the balance , and Make sure the Lug Nuts are tight.

let us know what you find.

Share this post


Link to post
Share on other sites
15 hours ago, G B L said:

Did this issue start before or after the tires? If after check the balance , and Make sure the Lug Nuts are tight.

let us know what you find.

Took back to tire place and all checked out good. Although they didn’t remove and shafts or anything. Still same. Hasn’t got worse or better. 

Share this post


Link to post
Share on other sites
On 9/16/2020 at 10:41 AM, No name displayed said:

Although they didn’t remove

Does that mean the tires? If so they should be put back on the balance machine..

Share this post


Link to post
Share on other sites

Honda has this issue in their 5-speed autos, a bad torque converter.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×