Jump to content
   
Sign in to follow this  
bozz

Cooling Fans blowing fuse

Recommended Posts

I have a 2013 ford transit van and the 50am engine bay fuse blows for the cooling fans...Any ideas that would cause that? wiring all seems good . Nothing smells burnt. When I replaced the fuse the fans kicked on like they are suppose too. Then the fuse blows..

Share this post


Link to post
Share on other sites
 

7 hours ago, bozz said:

I have a 2013 ford transit van and the 50am engine bay fuse blows for the cooling fans...Any ideas that would cause that? wiring all seems good . Nothing smells burnt. When I replaced the fuse the fans kicked on like they are suppose too. Then the fuse blows..

 

 

You will need to check the fan relay, connections, and the wiring.  Sometimes the relays go bad.  Sometimes you have bad grounding which blows the fuse.  Connections could be corroded.  Or there may be a frayed or worn wire which is causing an arc fault.  After testing the wiring for connectivity with a multimeter, you may need to physically follow and inspect the wires.  

Share this post


Link to post
Share on other sites

I will check the wiring and see what I can come up with. thanks for the input. I will update my findings in a few days..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×