Jump to content
   

Recommended Posts

Hi there!

Recently, my car had transmission failure.   It has less than 60000 but over the 5 year guarantee period by a month.  My car was fixed by a 3rd party.

I found out that Ford had issued earlier a technical service bulletin acknowledging that the 2010-2013 transit connect may exhibit an upshift flare or lack of 3rd and or 4th gear along with burnt automatic transmission fluid.  They have a direct clutch repair kit available to address these concerns.

I feel that Ford should have informed me of this issue so I can have it fix before my guarantee was over. 

Also, the NTSA has recalled several 2013 models  with the same transmission failure issue.  Unfortunately, Transit Connect is not among them.

Has anybody in this forum had the same problem with the transmission?

 

 

Share this post


Link to post
Share on other sites
   
Posted (edited)

You might want to post this elsewhere on the forum, under the "recalls & service bulletins." 

This header is for troubles with the forum itself.

 

There's also a "transmission" thread.

 

GK

Edited by Jiquay
additional evidence has come to light...

Share this post


Link to post
Share on other sites

Not sure where you are located, but you might want to check with your attorney generals office, You  might have some recourse it there was a TSB on your issue especially  considering the timing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×