Jump to content
   

Sgsf12

T.C. Member
  • Content Count

    22
  • Joined

  • Last visited

About Sgsf12

  • Rank
    New Member

Profile Information

  • Region
    Canada Quebec
  • My. T.C.'s Year
    None

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hehe after owning a few very unreliable but very fun vw's in my life, let's say I'm used to fixing little issues here and there. It's part of the fun.
  2. Fog lights are repaired! They must of forgot to change the fuse aftrr repairing the wiring. I just changed it and it works perfectly! Now let's move on to the alising door issue..
  3. Yes, I'm pretty happy with their service so far. These repairs weren't even covered by my warranty (mechanical fialures only). I will not be able to ask them to repair the door and the fog lights sadly, as they clearly stated that they wouldn't fix anything else that is not mechanical for free. I will try and look for busted fuses, relays or other stuff and keep you guys updated on the situation.
  4. Update! (again) Dealership finally found what was causing all the problems: wires that were passing inside the left front wheel well were rubbing against a metal piece which caused a few of them to get cut open and causing electrical shorts. Now, my headlights, flashers and airbags are working properly. But, my front fog lights still aren't working... And, a new problem appeared, my left sliding door does not respond to my key fob anymore. I cannot lock or unlock it with my key. On the right side, everything works fine. Let the adventure continue!
  5. I tried replacing the fuse for healights im the engine compartment. It's a 15A fuse, and as soon as I put in a mew one, it popped right away. There must be a short somewhere..
  6. Well, I started getting electrical issues (no headlights -low and high beams, no front fogs, no left turn signals, airbag light is on)... I hope it's only an open circuit short somewhere. I'm bringing the car back to dealership so he can fix it.
  7. Hi guys, I bought a used Tc 2012, 160k kms on the clock last week. Everything was doing fine after a fix on the gas pedal that was done prior to the sale. Yesterday, as I start the car, I noticed my headlights weren't turning on. Front fog lights aren't responding either, but the rears work. Also, left side turn signals don't work and the airbag light stays on in the cluster. I could use some help :s Thanks
  8. It's a really bad design from the engineers. After a few years and temperature changes, everything gets corroded in there and you're stuck with a pain job just to get a license plate on. For the euro brake light, I found one on ebay with all the necessary parts. My question is: taking out the original one on top of the roof will leave holes, is there a simple way to cover them without risking water leaks ?
  9. @Fifty150 Thanks for the help! I figured out the way to get the license plate screws out. I had to cut one of them and the other came out with some wd40. For the aftermarket radio, I found a Pioneer avh-280bt for sale in my local used classified website. I will be getting it along with a wireless rear view camera ordered from China.
  10. Thank you! Now for the fun part: 1- License plate screws are completely jammed in their metal fixings. There is no way to unscrew them without destroying them. I tried penetrating oil, heat and hand power. Do you think I should simply grind them off and install new ones ? 2- I want to get rid of the factory radio and install an aftermaket double din unit with bluetooth and rear view camera also. Do you guys have any experience with wireless rear view camera kits? Are they reliable ? 3- My third rear brake light that's located on the roof is a bit cracked and I thought of swapping it with a euro brake light instead. Is this a hard job? Where should I order the parts from ? Thanks again for the help By the way, I'm really surprised by the way this thing drives, apart from the slow and outdated transmission, the rest feels very nice!
  11. Update again: I finnaly got my Transit Connect after a few weeks of patience and headaches. The car wasn't moving because of a faulty gas pedal module. Car was sent to the Ford dealership where they found a corroded wire going to the pedal and causing the malfunction. I can finnaly say I have a 5 passenger, 4-window TC with no issues (so far) ! I will upload some pictures soon.
  12. Update #2 I went to see another Tc, 5 passenger version, 160kms, white, very clean. I took it for a test drive, but couldn't even leave the parking lot from the dealership. Check engine light appeared and all power was gone, like it went into security limp mode. Dealer promised to fix the issue before my next visit. Bad luck atrikes again!
  13. I know, but it still makes me sad. It took so long to find one with windows and a bench !
  14. Update: I had to return the car to the dealership. Transmission started sliding badly on the highway for a few minutes and they didn't want to fix the problem and they coudn't guarantee they would fix it if it reappers. So, I'm on the hunt again!
  15. Just got the Transit home and noticed a few things that needed my attention. First, the abs/tc light is on. Second, the tpms light is on. Third, the sliding doors don't unlock with my key fob. Any suggestions?
×