Jump to content

joshuamartin

T.C. Member
  • Content Count

    3
  • Joined

  • Last visited

About joshuamartin

  • Rank
    New Member

Profile Information

  • Region
    U.S. Northeast
  • My. T.C.'s Year
    2015

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Solved -- the fuse that i tapped into for the power reg (thought it was ignition fuse) actually was for these items. Added another fuse to the system and everything works as it should.
  2. Hi All, 2015 Transit Connect XLT here. I just was in the dash while installing a powered subwoofer unit underseat. The subwoofer works great, but now I noticed some other things wrong. The vent selector (what vents air comes from), temperature selector, and the A/C button doesn't work. The vent is stuck on feet. The temp is stuck on hot. The A/C button does not light when pressed. The fan speed works great! The rear defrost button works great! check fuses? check wire harness going to lowest center console panel? The dash is easy to take apart, but i'd like to hear if anyone has any better ideas. thanks in advance! Josh
  3. Sandra, I did this a couple weeks ago and ran into the same thing. I think you're talking about removing the brackets that hold the rear of the middle seats in place. There are actually bolts further back that also hold the brackets in place. You need to lift the carpet to access these additional T50 bolts (you could cut it, but this isn't reversible (unless you are a witch or other magic wielder)). To lift the carpet sufficiently, I had to remove the fasteners at the front edge of the carpet and on the sides by the door trim. HAVE FUN and ENJOY modding out your van!!!
×