Jump to content
  • Custom Search


ang210

Can I add OEM Cruise control to vehicle that came without it

Recommended Posts

drey, were you going over 25 MPH when trying to turn on & use the cruise control? I remember reading something awhile back that it doesn't work under 25 or so, so I've never tried personally. The only non-functional problem I had with mine was with only the CC option enabled, once I enabled ASL (which you've already done), mine works fine. When you click the "LIM On/Off" button to turn on CC, does the "Miles to Empty" on the dash change to "SET MPH"? LIM On/Off turns the cruise on & off when you need it or don't need it. 

Share this post


Link to post
Share on other sites

Hi jrm223, "miles to empty" does not change to "set mph" on the dash. seems like it did not program it. Yes, i did test the CC above 25 mph.

I did order a new scan tool that is recommended on the FORScan website and will see if that fixes the problem.

 

Any other ideas please let me know ? 

Edited by drey

Share this post


Link to post
Share on other sites

That's the same unit that I have. Sometimes the write fails, but Forscan will say that it failed, then I just make my changes again. If you connect and do a read of the BCM again, you can verify whether the changes were written. 

Share this post


Link to post
Share on other sites

Yes it did write, because the CC and ASL values are enabled. I do have a low tire pressure sensor issue that is bringing up a light on the dashboard. Can that cause an issue? 

Share this post


Link to post
Share on other sites

I wouldn't think so, but I honestly don't know. There's so many stupid nanny controls on vehicles nowadays that it really wouldn't surprise me! Y'know, something like "Oh, one of your tires is low on air, so we're not going to let you use cruise control until that's corrected." Haha. You need to fill them all up to spec anyway, so start your troubleshooting there and proceed onward. This next one shouldn't be required, but you could run the "PCM Relearn Procedure" (might be worded differently, it's the first one in the menu where you went to change the BCM specs) to see if that resolves it. And look through the DTC's next time, maybe one or more pointed to an issue that would help resolve the CC; I know most of them will just be generic ones about "lost communication with [xxx] module" from the rewrite, though.

Share this post


Link to post
Share on other sites

Hi, i cannot still get the cruise control to work.  The cruise control and ASL are enabled and the CC buttons illuminate. Please help to understand how to fix this code - mechanical failure in the steering wheel module?

IMG_1174.jpg

IMG_1175.jpg

Share this post


Link to post
Share on other sites

Are the 2014-2017 or 2018 cruise control steering wheels the same? Did you buy a 2016 steering wheel? The error message implies something in the steering wheel is not compatible.

Share this post


Link to post
Share on other sites

I’m not sure what year is the steering purchased from eBay. But called local Ford dealer and he said based off my vin# I need a manufacturer part # for the steering wheel bk2z-3600-aa. Not sure what year is this steering wheel. Purchased from eBay steering wheel is a ck41-3600-cb35b8. Let me know if using a different year steering wheel is an issue. 

Share this post


Link to post
Share on other sites

I googled your PN and it is for a Transit....not Transit Connect. This is a problem. Search for the PN you got from the dealer.

Share this post


Link to post
Share on other sites

Wow, with all the CANBUS and "universal parts bin" (or nearly universal), I would have expected the steering wheels to actually be the same. That full-size Transit one looks identical externally to the Transit Connect steering wheel I put in my van, but I guess the module inside it must be different & causing drey's issue. Time for him to return that one and get a TC steering wheel. The programming is already done, so just swapping on the right part will finally get him going. 

Share this post


Link to post
Share on other sites

Hi, so replaced the steering wheel with another one DT11-3600... and have the same issue. I think i have something going on with my configuration in the transit computer. When I reverted back to default, turned off the CC and ASL functions, my ABS and traction control lights lit up on the dashboard. When i enabled the CC again the lights on the dash disappeared by I cannot even change the ASL function. So how do i overwrite with my original configuration files in FORScan? I did backup these format files before I did my configurations originally. 

 

I want to overwrite to original configuration and then try to turn on CC and ASL again.  

Share this post


Link to post
Share on other sites

Here are the fault codes after I installed a 2015 transit connect steering wheel and enabled the CC. These codes are now different what i had before. No warning dash lights are on. 

Screenshot 2020-11-20 112040.png

Screenshot 2020-11-20 112102.png

Share this post


Link to post
Share on other sites

drey,

 

I agree you may have a mis-configuration in the BDYCm or IPC modules. You load configurations using the "as built" version of the modules. You can load the backup you have saved (good job saving this!) or you can get the factory configuration from the Motorcraft website (newer versions of Forscan have a button that will do this). Here are some tutorials you should read to make sure you do things properly. 

 

https://docs.google.com/document/d/1-8dKaS_Spu4Zw4hV_CrKC4tLoP9G8yejqegF1wxIqxY/edit

http://www.2gfusions.net/showthread.php?tid=4573

Motorcraft site: https://www.motorcraftservice.com/asbuilt (you need to enter the country and accept cookies, then logout and try again to get access..or some other steps to gain access. This should be covered in the tutorials)

 

 

Share this post


Link to post
Share on other sites

Here is info on the DTC

U2101 - Ford Diagnostic Trouble Code (DTC) Definition, Causes and Diagnosis (dtcdecode.com)

 

Try resetting the PCM using Forscan. Another way to reset everything is to disconnect the battery for 10-15 minutes. Don't do any recalibrations....just a module reset.

 

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×