Jump to content

Welcome to the Ford Transit Connect Forum

Welcome to the Ford Transit Connect Forum - the largest Ford Transit forum discussion board.  Like most online communities, you must register to post and take advantage of other features that this community has to offer, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Transit Connect Forum by signing in or creating an account.
• Receive special product discounts
• Invitations to events
• Start new topics and reply to others
• Subscribe to topics and forums to get email updates
• Get your own profile page and make new friends
• Send personal messages to other members
• Create an album and post photos. . .More!

Click here to create an account now.

 

transit connect guest message logo.png


   
  •  
    Custom Search





Sign in to follow this  
chiloperez

speed blower control

Recommended Posts

the speed blower control is working only on 3 and 4 speed; I all ready replace the blower motor resistor and nothing happened. what else can be

Share this post


Link to post
Share on other sites
 

Did you check the plug? I had the plug molten due to high load (stuck pollen filter)

Share this post


Link to post
Share on other sites

the plugs look fine and I tested it with the blower motor, removed the area where is mounted and I did disconnect the blower motor resistor. It only works on the 4 speed and reconnected again and still working on 3 and 4 speed.

Share this post


Link to post
Share on other sites

I think I have read about it (3-4 speed only) in UK forum. Can't recall.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×