Jump to content

Welcome to the Ford Transit Connect Forum

Welcome to the Ford Transit Connect Forum - the largest Ford Transit forum discussion board.  Like most online communities, you must register to post and take advantage of other features that this community has to offer, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Transit Connect Forum by signing in or creating an account.
• Receive special product discounts
• Invitations to events
• Start new topics and reply to others
• Subscribe to topics and forums to get email updates
• Get your own profile page and make new friends
• Send personal messages to other members
• Create an album and post photos. . .More!

Click here to create an account now.

 

transit connect guest message logo.png


   
  •  
    Custom Search





Hal

ALERT Power Steering Hose

Recommended Posts

Hal    8

ALERT

Yesterday my power steering started to get very stiff in slow speed turns. I called my dealership and took it in today.

There is a bolt on the bottom of the battery tray which can rub on a power steering hose eventually wearing thru causing complete fluid loss. By the time I got my TC to the dealership it had pumped most of the steering fluid out.

According to the mechaic at the dealership this is the 3rd TC they have had this problem with.

I suggest that everyone get their TC checked for this problem. My Tc only has 3500 miles on it so I don't think it is a problem with all TC's but you should check it anyhow.

Share this post


Link to post
Share on other sites
 

ALERT

Yesterday my power steering started to get very stiff in slow speed turns. I called my dealership and took it in today.

There is a bolt on the bottom of the battery tray which can rub on a power steering hose eventually wearing thru causing complete fluid loss. By the time I got my TC to the dealership it had pumped most of the steering fluid out.

According to the mechaic at the dealership this is the 3rd TC they have had this problem with.

I suggest that everyone get their TC checked for this problem. My Tc only has 3500 miles on it so I don't think it is a problem with all TC's but you should check it anyhow.

Thank you mine has 400 miles on it (I just got it) I will look at that and maybe move it or tape it up of some how sheild it

Share this post


Link to post
Share on other sites

When I purchased my TC i drove about 40 miles and stopped for something to eat. After eating I went out and the car would not start, I hadn't even had it an hour and already a problem. The car was towed and found to have a bad battery. I talk to the dealship and they went and check their TCs and they too had bad batteries. it's my understand they call Ford and Ford confirmed TCs were coming from the factory with bad batteries. I now have a new battery. Hope this help others

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×