Jump to content

Welcome to the Ford Transit Connect Forum

Welcome to the Ford Transit Connect Forum - the largest Ford Transit forum discussion board.  Like most online communities, you must register to post and take advantage of other features that this community has to offer, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Transit Connect Forum by signing in or creating an account.
• Receive special product discounts
• Invitations to events
• Start new topics and reply to others
• Subscribe to topics and forums to get email updates
• Get your own profile page and make new friends
• Send personal messages to other members
• Create an album and post photos. . .More!

Click here to create an account now.

 

transit connect guest message logo.png


   

Jling

T.C. Member
  • Content count

    4
  • Joined

  • Last visited

  • Days Won

    2

Jling last won the day on April 12

Jling had the most liked content!

About Jling

  • Rank
    New Member

Profile Information

  • Region
    U.S. Northeast
  • My. T.C.'s Year
    2014
  1. I’m showing the the miles that are on my van in this picture. Sorry, I’m not sure what you mean when you say low cluster. This is the digital display that is between the tachometer and the speedometer on my guage cluster. Yes it is set on the cruise control setting.
  2. Hey thanks Here’s a pic of the 400k van. I actually put 8k on the on the replacement engine already.
  3. I actually run a courier route delivering meds to nursing homes. Ill posts some pics of the parts TC I think I have a few of my van as well. As far as any other issues I’ve had along the way, the third brake light died so I had to replace that around 350k . The radio died around 275k “ I have the CD player with the sync system “. Beleive it or not I didn’t even replace brakes until 400k and they still would’ve passed inspection. I had the trans serviced at 160k then I just changed the fluid once myself around 380k. I’m on my 4th set of tires. That’s all I can really think of for now. I also have a 2014 transit connect wagon that I’m fixing up. Here are some pics. The white one is the parts unit. The black one with the white hood is the one I’m fixing up. Ill get some pics of my transit I use every day tomorrow for you guys.
  4. I bought my 2014 TC in April of 2015 with 37 miles on it. It has servered me well for my delivery route that I run. “ almost 600 miles a day” The engine lost compression in cylinder 1. I think it had something to do with the valves. “ I drive pretty hard to get my route done so the poor van has taken a beating. My oil was changed every 10k and it served me well up until it started missing at 409k. I bought a wrecked 2014 TC with 100k on it from copart and and swapped the motor and trans now it’s back in service. Im hoping to go another 300-400k! I have a ton of parts from the wrecked TC if anyone needs anything.
×