Jump to content

Welcome to the Ford Transit Forum

Welcome to the Ford Transit Connect Forum - the largest Ford Transit forum discussion board.  Like most online communities, you must register to post and take advantage of other features that this community has to offer, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Transit Connect Forum by signing in or creating an account.
• Receive special product discounts
• Invitations to events
• Start new topics and reply to others
• Subscribe to topics and forums to get email updates
• Get your own profile page and make new friends
• Send personal messages to other members
• Create an album and post photos. . .More!

Click here to create an account now.


   

Jes1

T.C. Member
  • Content count

    1
  • Joined

  • Last visited

Everything posted by Jes1

  1. I have a 2010 Ford Transit Connect XLT. The sliding doors unlocking. they will lock up as soon as I hit the button but they won't unlock. They don't make any weird sound like everyone else says. But it does sound like the motor has no power in trying to unlock it. I took the door panel part and I took the lock actuator out and took some pictures everything seems to be working fine with the motor. But the motor does seem to be a little bit on the small side and looks pretty cheap. Here are some pictures I hope someone can give me some insight. I guess the pictures I took were too large in memory. I cant upload them.
×