Jump to content

Welcome to the Ford Transit Connect Forum

Welcome to the Ford Transit Connect Forum - the largest Ford Transit forum discussion board.  Like most online communities, you must register to post and take advantage of other features that this community has to offer, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Transit Connect Forum by signing in or creating an account.
• Receive special product discounts
• Invitations to events
• Start new topics and reply to others
• Subscribe to topics and forums to get email updates
• Get your own profile page and make new friends
• Send personal messages to other members
• Create an album and post photos. . .More!

Click here to create an account now.

 

transit connect guest message logo.png


   

paskenta

T.C. Member
  • Content count

    3
  • Joined

  • Last visited

  1. I JUST DISCOVERED THAT THE SECURITY SYSTEM ON MY 2010 T/C BLOCKED ALL ATTEMPTS TO START. IT ALL BEGAN WHEN I TRIED TO START MY T/C AFTER IT HAD SAT UNUSED FOR SOME TIME. IT BEHAVED LIKE THE BATTERY WAS LOW. I TRIED A JUMPER CABLE, NO GO. THEN I TRIED CHARGING THE BATTERY FOR SEVERAL HOURS, NO GO. VISITED THE LOCAL FORD DEALER HERE AND DESCRIBED THE SYMPTOMS: FAILURE TO CRANK, WITH A FLASHING ALARM SYSTEM LAMP ON THE INSTRUMENT PANEL. OWNERS MANUAL HINTS AT SOME SORT OF KEY PROBLEM. TRIED BOTH KEYS SAME NO GO. TOW TRUCK CARTED IT TO DEALER. FEW HOURS LATER DEALER HASN'T A CLUE. FORD TECHNICIAN AT A LOSS FOR SOLUTION. HE CONTACTS FACTORY FOLKS WHOM RECOMMEND HE READ A SPECIAL SERVICE BULLETIN, "OASIS SPECIAL SERVICE MESSAGE 21205" AHA MOMENT...NOT MENTIONED ANYWHERE ELSE, THAT THE SECURITY SYSTEM ON SEVERAL FORD PRODUCTS, HAS A LIMIT TO ITS COMPUTER TIMER FOR KEEPING TRACK OF THE TIME THE KEY HAS BEEN IN THE OFF POSITION. LIKE IF YOU LET YOUR T/C SIT FOR MORE THAN 50 DAYS WITHOUT STARTING IT. SHOULD YOU NOT START YOUR FORD PRODUCT FOR A PERIOD GREATER THAN 50 DAYS, LIKE IN MY CASE IT TURNED OUT TO BE 52 DAYS, THE COMPUTER BLOCKS ALL ATTEMPTS TO START BY ANY MEANS. THE CODES SHOW YOUR COMPUTER KAPUT. FORTUNATELY WITHIN THE SPECIAL SERVICE MESSAGE THEY DESCRIBE THE SIMPLE SOLUTION...DISCONNECT THE NEGATIVE BATTERY CABLE FOR 30 SHORT SECONDS, AND ALL IS WELL AGAIN. UNFORTUNATELY, THE COST OF THE TOW, THE TECHNICIANS TIME , ETC ARE CATIGORICALLY DENIED BY FOMOCO IN THE SPECIAL SERVICE MESSAGE. IF ANYONE HAS READ ANYTHING BY FORD TO BE AWARE OF THIS ISSUE, I WOULD LIKE TO SEE IT. AS FORD TRANSIT CONNECT OWNERS/OPERATORS I BELIEVE WE SHOULD HAVE HAD SOME WARNING FROM FORD AS TO HOW MUCH TIME WE CAN LET OUR VEHICLES REMAIN IDLE. PASS THIS INFO ALONG TO OTHER FORD OWNERS, COULD SAVE THEM AN EMBARRASSING MOMENT AND NEEDLESS EXPENSES.
  2. Speed Control

    Did you ever resolve the problem with the aftermarket cruise control? Was it a Rostra?
  3. Stan, I installed the Rostra 250-1857 unit and it caused the transmission to attempt to take off in second and jump into low. The Ford dealer removed the wire to the vss and the trans is back to normal. Unfortunately the folks at Rostra are witch hunting and are questioning my wiring and soldering techniques. Contact them and complain, tell them you know of others with problems.

  4. Speed Control

    Just bought a TC XL cargo van, bare bones, and am interested in installing an aftermarket Speed control (cruise control). Anyone know of a good one? Have experience with Rostra on my Yaris, didn't like the mounting position Toyota used for aftermarket. Placed the lever/control about "seven o'clock" on the steering column, not visible, and doesn't illuminate the factory cluster alert lite for cruise control in operation.
×