Jump to content

Welcome to the Ford Transit Connect Forum

Welcome to the Ford Transit Connect Forum - the largest Ford Transit forum discussion board.  Like most online communities, you must register to post and take advantage of other features that this community has to offer, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Transit Connect Forum by signing in or creating an account.
• Receive special product discounts
• Invitations to events
• Start new topics and reply to others
• Subscribe to topics and forums to get email updates
• Get your own profile page and make new friends
• Send personal messages to other members
• Create an album and post photos. . .More!

Click here to create an account now.


transit connect guest message logo.png



T.C. Member
  • Content count

  • Joined

  • Last visited

About dazzerbone2003

  • Rank
    New Member

Profile Information

  • Region
    European Union
  1. Slow warming up

    Hi, I have a 2015 1.6 115psi L1 van, now the weather here in the uk is getting colder i have noticed how long it takes the van to warm up, if i get a ckear run in the morning it is warm about 8-10 mins if me driving without any delays, i am usually on the motorway after about 7 or 8 minutes, today i left my house at rush hour and after 20 mins of being in very slow moving traffic no warm air was coming out of the heater at all. is this normal? i have had cars and vans is the past that i could turn on 5-10 mins before leaving the house and when u get in the motor its warm. could anything be wrong, it does get warm just not when its not moving