Jump to content

Welcome to the Ford Transit Connect Forum

Welcome to the Ford Transit Connect Forum - the largest Ford Transit forum discussion board.  Like most online communities, you must register to post and take advantage of other features that this community has to offer, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Transit Connect Forum by signing in or creating an account.
• Receive special product discounts
• Invitations to events
• Start new topics and reply to others
• Subscribe to topics and forums to get email updates
• Get your own profile page and make new friends
• Send personal messages to other members
• Create an album and post photos. . .More!

Click here to create an account now.

 

transit connect guest message logo.png


   

robbie

T.C. Member
  • Content count

    1
  • Joined

  • Last visited

About robbie

  • Rank
    New Member

Profile Information

  • Region
    European Union
  1. i have a 2014 ford transit connect ltd had it in fords over a battery problem. the mechanics in my ford dealers are a bunch of stupid monkeys. they call me after charging the battery to ask me if i have an immobiliser on my clifford add on alarm . two days later the service man ring up sorry mr coleman we cant get your van started . you don't have any ignition or cluster lights .so i call the auto elec who works on my van . after arriving he has it going in ten minutes . the battery was that low so the brain went into hibernation to protect it. the auto elect just unplugs the brain under the wing and leaves for a minute re plugs it in hey presto we have ignition
×