Jump to content

Welcome to the Ford Transit Connect Forum

Welcome to the Ford Transit Connect Forum - the largest Ford Transit forum discussion board.  Like most online communities, you must register to post and take advantage of other features that this community has to offer, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Transit Connect Forum by signing in or creating an account.
• Receive special product discounts
• Invitations to events
• Start new topics and reply to others
• Subscribe to topics and forums to get email updates
• Get your own profile page and make new friends
• Send personal messages to other members
• Create an album and post photos. . .More!

Click here to create an account now.

 

transit connect guest message logo.png


   
  •  
    Custom Search





Powertrain Tech

Sign in to follow this  

83 topics in this forum

    • 1 reply
    • 43,644 views
  1. Traction Control

    • 39 replies
    • 25,730 views
    • 21 replies
    • 24,208 views
  2. Transmission Failures?

    • 18 replies
    • 20,187 views
  3. FSWERKS Turbo

    • 35 replies
    • 13,204 views
    • 4 replies
    • 11,156 views
  4. Adding Power

    • 12 replies
    • 10,098 views
    • 0 replies
    • 9,672 views
  5. manual tranny

    • 17 replies
    • 9,282 views
    • 3 replies
    • 8,734 views
  6. Diesel

    • 8 replies
    • 8,132 views
  7. 92mph

    • 13 replies
    • 7,585 views
    • 143 replies
    • 7,361 views
  8. Turbocharger?

    • 11 replies
    • 7,339 views
  9. starting problems

    • 0 replies
    • 7,226 views
    • 2 replies
    • 6,870 views
    • 2 replies
    • 6,374 views
  10. Accelerator lag

    • 12 replies
    • 6,144 views
    • 3 replies
    • 6,134 views
    • 5 replies
    • 5,795 views
  11. Temperature sender fault?

    • 4 replies
    • 5,639 views
    • 1 reply
    • 5,426 views
  12. funny noise

    • 1 reply
    • 5,259 views
  13. Check Engine light

    • 6 replies
    • 5,159 views
  14. Transmission Issue ?

    • 5 replies
    • 4,909 views
Sign in to follow this  
×